Announcement

Collapse
No announcement yet.

Members Only Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Members Only Issues

    Hey club, I joined last week and tried to access the members only section using the username and password that was supplied upon checkout. Those tow things do not seem to work. I attempted to email the club at the [email protected] but the email was returned. Any idea what's going on? Thanks,

    John

  • #2
    I'm having the same issues.

    Comment


    • #3
      Ok, I spoke to Malcolm (the club pres) and he said the following "I apologize for all the issues you have encountered since joining the club. We are in the process of building a new website so our current one has not been updated in months." He offered to help me with whatever it was that I needed. Good guy.

      Comment


      • #4
        Originally posted by S-Car-Go View Post
        Ok, I spoke to Malcolm (the club pres) and he said the following "I apologize for all the issues you have encountered since joining the club. We are in the process of building a new website so our current one has not been updated in months." He offered to help me with whatever it was that I needed. Good guy.
        I received my member info in paper mail (love the 'sticker') and the new passwords worked for me.

        Comment


        • #5
          If you are newly registered to the discussion forums, there is a process that takes place before you can post or access special sections. It is unrelated to club membership otherwise. Our website has been hacked a few times and the last was by far the worst. We now have robot registrations happening every day and do our best to keep them out. That sometimes means that legitimate registrations get tossed by mistake. If your registration was denied, send an email to the administrator. It will be admitted once we know you are people, not hacker machines.

          Thanks!
          1971 R10 - R1192

          Comment

          Working...
          X